Degredation of Performance with Office Documents
Incident Report for Documents
Resolved
After extensive monitoring, we are confident the issue is resolved.

Thank you for your patience and understanding!
Posted Oct 20, 2021 - 19:03 UTC
Monitoring
We have identified the underlying issue and have deployed a fix. Monitoring shows that systems are currently stable, however asynchronous merges, as well as Podio and Pipedrive jobs are currently backlogged and processing slowly. We will update once the majority of the job queues are processed.
Posted Oct 20, 2021 - 16:46 UTC
Investigating
We are aware there is an issue with users seeing severe degradation involving the conversion of Office documents (Word, Excel, PPT). We will update once we have identified the cause of the issue.
Posted Oct 20, 2021 - 14:21 UTC
This incident affected: API & Document Generation.