Issue affecting account sign ups and changes
Incident Report for Documents
Resolved
After extensive monitoring, we are confident the published fix has resolved the issue. Thank you for your patience and understanding!
Posted Jun 08, 2021 - 20:36 UTC
Monitoring
A fix has been deployed and we are monitoring the results. At this time, we are confident that functionality is fully restored.
Posted Jun 08, 2021 - 18:04 UTC
Update
We have identified the cause of the Billing system issues and are working toward deploying a fix.
Posted Jun 08, 2021 - 17:48 UTC
Investigating
We are aware there is an issue with our internal Billing system that is affecting users' ability to sign up for new accounts and to upgrade or downgrade their accounts. At the moment, we are still investigating what, if any, impact this may have on users with existing accounts outside of the upgrade/downgrade functions. We will update once we have identified the root cause and/or if the scope of affected functions changes.
Posted Jun 08, 2021 - 17:31 UTC
This incident affected: Website & Management Portal.