Degraded Performance with Integrations and Deliveries
Incident Report for WebMerge
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 21:13 UTC
Investigating
We are currently investigating this issue.
Posted Dec 04, 2019 - 14:36 UTC
This incident affected: Third Party Integrations (Podio API) and SendGrid SMTP.